Docker学习之“CentOS 8安装 Docker”

技术文章 1年前 (2020) 完美者
707 0

标签:inf   str   image   安装   技术   install   inux   led   linux   

CentOS 8在安装Docker的时候报错“Error: Problem: package docker-ce-3:19.03.12-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed”

Docker学习之“CentOS 8安装 Docker”

解决方法

  1. 先安装低版的“docker”
    # yum install -y docker-ce --nobest
    Docker学习之“CentOS 8安装 Docker”
    Docker学习之“CentOS 8安装 Docker”
  2. 下载支持的“containerd.io”,然后重新下载“docker”
    # wget https://download.docker.com/linux/centos/7/x86_64/edge/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm
    # yum install -y containerd.io-1.2.6-3.3.el7.x86_64.rpm
    # yum install -y docker-ce
    Docker学习之“CentOS 8安装 Docker”
    Docker学习之“CentOS 8安装 Docker”
    Docker学习之“CentOS 8安装 Docker”

Docker学习之“CentOS 8安装 Docker”

标签:inf   str   image   安装   技术   install   inux   led   linux   

原文地址:https://blog.51cto.com/14033577/2528061

版权声明:完美者 发表于 2020-09-17 12:45:25。
转载请注明:Docker学习之“CentOS 8安装 Docker” | 完美导航

暂无评论

暂无评论...